Subversion - $Id$ funktioniert nicht?

Ihr habt ein Problem mit C++ oder anderen Sprachen ? Dann seit Ihr in diesem Forum genau richtig! Hier können alle Fragen gestellt werden, die mit Programmierung (MorphOS, Linux, BeOS, BSD,...) zu tun haben.

Moderatoren: analogkid, roschmyr

ShawnBaxe
Stammgast
Stammgast
Beiträge: 23
Registriert: 02 Dez 2008, 00:20

Subversion - $Id$ funktioniert nicht?

Beitragvon ShawnBaxe » 17 Jul 2009, 17:47

Meine Sources haben alle den gleichen Kopf:

Code: Alles auswählen

//------------------------------------------------
// Copyright (c) 2009 Kaya Dogan
//------------------------------------------------
// $Id$
//------------------------------------------------


und ich habe alle mit svn propset svn:keyword "id" dateiname bearbeitet und ins Repository geladen. Trotzdem - auch nach einem kompletten Checkout, steht immer noch $Id$ in den Files, anstelle der Revision, des Datums und des Autors. Hat jemand ne Idee, woran das liegt? Gleiches passiert übrigens auch, wenn ich statt $Id$ z.B. $Rev$ oder $Author$ verwende.[/code]

Benutzeravatar
psd
Tastaturkiller
Tastaturkiller
Beiträge: 384
Registriert: 20 Mär 2004, 18:18
Wohnort: Ingelheim

Beitragvon psd » 19 Jul 2009, 04:00

Du schreibst hier einmal "Id" und einmal "id", liegt's vielleicht daran?

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1349
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Beitragvon DrB » 19 Jul 2009, 10:24

Ich meine, bei SVN musste man extra festlegen, dass die keywords substituiert
werden sollen, das passiert nicht einfach so (benutze selber nur CVS so dass ich
das jetzt auch nicht ganz genau weiss).

ShawnBaxe
Stammgast
Stammgast
Beiträge: 23
Registriert: 02 Dez 2008, 00:20

Beitragvon ShawnBaxe » 24 Jul 2009, 14:08

Hoppla...nu läufts ;) Es lag offenbar tatsächlich am case...werd mich wohl nie an case-sensitive-klamotten in der shell gewöhnen lol


Zurück zu „Code-Küche“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast