Probleme mit MorphOS 2.7 auf dem Mini

MacMini, PowerMac, eMac, Powerbook
Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 14:55

Hi,

ich habe den Mini mit 32 MB VRAM, 1 GB RAM und 1,42 GHz CPU.

Wenn ich zwei MUI-Programme öffne, dann fängt der Mauszeiger an zu ruckeln und zu springen. Ich nutze z.B. auch gerne den MUI-OWB mit dem MPlayer zusammen. Wenn ich eine Seite mit dem OWB öffne, dann passiert es öfter, dass das Webradio stottert. Diese Probleme habe ich schon immer unter MorphOS auf dem Mini. Der Mac Mini ist aber einwandfrei in Ordnung. Ich habe neben MorphOS noch das neue Lubuntu 12.04 und Mac OS X 10.5.8 Leopard und Mac OS X 10.3.9 Panther installiert. Obwohl gesagt wird, dass MorphOS schneller und schlanker sein soll als die o.g. Systeme, sind bei mir die OS X-Systeme und (L)Ubuntu genauso schnell und bekommen das mit dem Multitasking perfekt hin. Obwohl Linux extrem aufgebläht ist, kann ich den neuesten Firefox 11 und den MPlayer gleichzeitig benutzen ohne das etwas ruckelt oder der Sound stottert.

Habe ich etwas vergessen einzustellen unter MorphOS? Oder fehlt mir irgendein Treiber-Paket?

Achja, es gibt unter Lubuntu auch ein Browser der so wie unser OWB ist. Dieser heißt Midori und baut genauso wie der OWB auf Webkit auf, ist aber ein wenig schneller im Seitenaufbau.

Vielleicht kann MorphOS 3.0 mit meinen anderen Systemen von der Geschwindigkeit her wieder gleichziehen. Ich habe gelesen, dass der AGP-Treiber verbessert wurde.
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.

Benutzeravatar
Kronos
Moderator
Moderator
Beiträge: 719
Registriert: 07 Sep 2003, 01:10
Wohnort: Hagen

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Kronos » 21 Apr 2012, 15:25

Naja, der 1te Verdacht ist da ja immer das das VMEM am Ende ist (kann bei nur 32MB schnell paasieren).

Am MIni (1.5er mit 64MB) hab ich immer nur 16bit Farbtiefe aktiviert (aber halt mit Full-HD) und selbst da häng ich grad schon bei 21.4MB in Benutzung ....

Also "graphicsmemory" in den Screenbar-Modulen aktivieren und einfach mal schauen ob es da einen Zusammenhang gibt.

Wenn ja, Auflösung/Tiefe reduzieren oder eben "enhanced display" abschalten.
!! Bin Wichtig !!

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Thore » 21 Apr 2012, 15:28

Kann es sein daß beim MorphOS OWB das Cairo noch keine Hardwarebeschleunigung hat? Das könnte die Geschwindigeitsunterschiede erklären.
http://www.disk-doktor.de

Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 15:41

Kronos hat geschrieben:Naja, der 1te Verdacht ist da ja immer das das VMEM am Ende ist (kann bei nur 32MB schnell paasieren).

Am MIni (1.5er mit 64MB) hab ich immer nur 16bit Farbtiefe aktiviert (aber halt mit Full-HD) und selbst da häng ich grad schon bei 21.4MB in Benutzung ....

Also "graphicsmemory" in den Screenbar-Modulen aktivieren und einfach mal schauen ob es da einen Zusammenhang gibt.

Wenn ja, Auflösung/Tiefe reduzieren oder eben "enhanced display" abschalten.


Aber warum haben die aufgeblähten Systeme wie Mac OS X und Lubuntu 12.04 diese Probleme nicht? Ich habe gerade eben das Monster Firefox 11, VLC, Gnumeric, Abiword und Midori offen unter der Entwicklungsversion Lubuntu 12.04 offen und es gab keine Probleme.

Was bewirkt die Einstellung "enhanced display"? Und bringt es was für meinen Mini, wenn MorphOS 3.0 einen besseren AGP-Support hat?
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1350
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon DrB » 21 Apr 2012, 15:45

Thore hat geschrieben:Kann es sein daß beim MorphOS OWB das Cairo noch keine Hardwarebeschleunigung hat? Das könnte die Geschwindigeitsunterschiede erklären.


Aber auch das ruckeln des Mauszeigers, das laesst darauf schliessen das memory bloecke durch
die Gegend geschoben werden mussen. Ich tippe auch mal auf das Video Mem, da kommt man
mit grossen Aufloesungen und Dreifachpufferung schnell an die Grenzen.

Benutzeravatar
Kronos
Moderator
Moderator
Beiträge: 719
Registriert: 07 Sep 2003, 01:10
Wohnort: Hagen

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Kronos » 21 Apr 2012, 15:54

Amiga4k hat geschrieben:Aber warum haben die aufgeblähten Systeme wie Mac OS X und Lubuntu 12.04 diese Probleme nicht?


Weil da das GFX-System grundsätzlich anders aufgebaut ist ? (*doh*) Ehrlich gesagt find ich ein "Desktop-Linux" wie Ubuntu selbst hier auf nem Athlonichweissnichtwas mit 2x3GHz immer noch nur als träge, zäh und lustlos (was aber weniger am GFX-System liegt das nebenbei auch Müll ist ...).

Wär aber schön wenn du anstatt hier mit nutzlosen Vergleichen Grundsatzdiskussionen loszutreten einfach mal das probieren würdest was geraten wurde und dannach deine Ergebnisse posten würdest.

Ja dann, dann könnte dir vielleicht sogar geholfen werden :roll:
Zuletzt geändert von Kronos am 21 Apr 2012, 15:57, insgesamt 1-mal geändert.
!! Bin Wichtig !!

Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 15:57

Auch wenn es diese Probleme gibt und Linux sogar bessere Ergebnisse liefert, finde ich es trotzdem gut, dass es MorphOS für den Mini gibt und bereue den Kauf nicht :) Obwohl ich etwas erschrocken war, dass AROS extrem gute Fortschritte gemacht hat und jetzt sogar einen besseren MUI-OWB hat als MorphOS und sehr gut benutzbar ist. Trotzdem stehe ich weiterhin zu OS 4.1 und MorphOS ;) Aber zurück zum Thema. Vielleicht ist MorphOS 3.0 besser optimiert für den Mini (Stichwort AGP-Support) :)
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.


Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 16:16

Kronos hat geschrieben:Naja, der 1te Verdacht ist da ja immer das das VMEM am Ende ist (kann bei nur 32MB schnell paasieren).

Am MIni (1.5er mit 64MB) hab ich immer nur 16bit Farbtiefe aktiviert (aber halt mit Full-HD) und selbst da häng ich grad schon bei 21.4MB in Benutzung ....

Also "graphicsmemory" in den Screenbar-Modulen aktivieren und einfach mal schauen ob es da einen Zusammenhang gibt.

Wenn ja, Auflösung/Tiefe reduzieren oder eben "enhanced display" abschalten.


Enhanced display abschalten hat leider nichts gebracht. Die Auflösung beträgt zur Zeit 1280x1024. Ein kleinere Auflösung sieht auf dem Monitor unscharf aus. Und warum soll ich die Farbtiefe reduzieren, wenn X11 auch ohne Probleme die Farbtiefe darstellen kann. Die anderen Systeme zeigen in diesem Fall, dass noch Optimierungspotential für MorphOS vorhanden ist ;)
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1690
Registriert: 12 Sep 2003, 15:55

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Andreas_Wolf » 21 Apr 2012, 16:37

> warum haben die aufgeblähten Systeme wie Mac OS X und Lubuntu 12.04 diese Probleme nicht?

Weil sie ein ausgefeilteres VRAM-Management als MorphOS haben. Auf MorphZone gibt es einen Thread zu genau diesem Thema:

http://www.morphzone.org/modules/newbb_ ... 83&forum=3

> Was bewirkt die Einstellung "enhanced display"?

Im Grunde das gleiche, was unter OS4 das Aktivieren von Compositing bewirkt.

> bringt es was für meinen Mini, wenn MorphOS 3.0 einen besseren AGP-Support hat?

Ja, da dadurch die Kopiervorgänge zwischen System-RAM und VRAM beschleunigt werden.

> Obwohl ich etwas erschrocken war, dass AROS [...] jetzt sogar einen besseren MUI-OWB hat als MorphOS

Falls du hier auf den JavaScript-JIT anspielst: Das war abzusehen, dass ein WebKit-Browser wie MUI-OWB den auf AROS/x86 bekommt, da der JIT für x86 und ARM nun mal Teil des WebKit-Projekts selbst ist. Für PPC gibt's den leider nicht. Mit AROS an sich hat das nichts zu tun.

> Vielleicht ist MorphOS 3.0 besser optimiert für den Mini (Stichwort AGP-Support)

Ja, AGP-Transfers sollen ab MorphOS 3.0 unterstützt werden. Damit zieht MorphOS zumindest in diesem Punkt mit den anderen OS gleich.
Zuletzt geändert von Andreas_Wolf am 21 Apr 2012, 16:50, insgesamt 2-mal geändert.
http://www.pegasosforum.de/download/file.php?id=855

Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 16:45

Andreas_Wolf hat geschrieben:> warum haben die aufgeblähten Systeme wie Mac OS X und Lubuntu 12.04 diese Probleme nicht?

Weil sie ein ausgefeilteres VRAM-Management als MorphOS haben. Auf MorphZone gibt es einen Thread zu genau diesem Thema:

http://www.morphzone.org/modules/newbb_ ... 83&forum=3

> Was bewirkt die Einstellung "enhanced display"?

Im Grunde das gleiche, was unter OS4 das Aktivieren von Compositing bewirkt.

> bringt es was für meinen Mini, wenn MorphOS 3.0 einen besseren AGP-Support hat?

Ja, da dadurch die Kopiervorgänge zwischen System-RAM und VRAM beschleunigt werden.


Danke!

Bitte nicht denken, dass ich MorphOS schlecht machen möchte. Ich finde es gut, dass es MorphOS auf dem Mini gibt. Und ich benutze es auch häufig und bin eigentlich zufrieden. Die Mausruckler oder das Stottern des MPlayers wenn ich z.B. den Bildschirmschoner verlasse, ignoriere ich einfach. Ich habe durch die OS X-Installationen und Lubuntu-Installation einfach die Möglichkeit gehabt, direkt zu vergleichen und wollte dieses auch einfach mal posten. Ich glaube, dass es auch wichtig ist, über Nachteile zu schreiben.
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1350
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon DrB » 21 Apr 2012, 18:07

Amiga4k hat geschrieben:Bitte nicht denken, dass ich MorphOS schlecht machen möchte. Ich finde es gut, dass es MorphOS auf dem Mini gibt. Und ich benutze es auch häufig und bin eigentlich zufrieden. Die Mausruckler oder das Stottern des MPlayers wenn ich z.B. den Bildschirmschoner verlasse, ignoriere ich einfach. Ich habe durch die OS X-Installationen und Lubuntu-Installation einfach die Möglichkeit gehabt, direkt zu vergleichen und wollte dieses auch einfach mal posten. Ich glaube, dass es auch wichtig ist, über Nachteile zu schreiben.


Natuerlich, wobei ich von einem Problem ausgehe. Ich (allerdings mit 64 MB Videomem) habe solche
Probleme nicht und OSX kommt mir auch kein Stueck fixer vor (eher im Gegenteil). Das haengt natuerlich
alles sehr stark davon ab, was du genau machst und wie, mit welchem mplayer und optionen, abspielst
und was sonst noch so im Hintergrund laeuft.

Das Video memory hattest du, wie geraten, ueberprueft?

Amiga4k
Articia-Verehrer
Articia-Verehrer
Beiträge: 175
Registriert: 23 Aug 2010, 17:29
Wohnort: München
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Amiga4k » 21 Apr 2012, 18:26

DrB hat geschrieben:
Amiga4k hat geschrieben:Bitte nicht denken, dass ich MorphOS schlecht machen möchte. Ich finde es gut, dass es MorphOS auf dem Mini gibt. Und ich benutze es auch häufig und bin eigentlich zufrieden. Die Mausruckler oder das Stottern des MPlayers wenn ich z.B. den Bildschirmschoner verlasse, ignoriere ich einfach. Ich habe durch die OS X-Installationen und Lubuntu-Installation einfach die Möglichkeit gehabt, direkt zu vergleichen und wollte dieses auch einfach mal posten. Ich glaube, dass es auch wichtig ist, über Nachteile zu schreiben.


Natuerlich, wobei ich von einem Problem ausgehe. Ich (allerdings mit 64 MB Videomem) habe solche
Probleme nicht und OSX kommt mir auch kein Stueck fixer vor (eher im Gegenteil). Das haengt natuerlich
alles sehr stark davon ab, was du genau machst und wie, mit welchem mplayer und optionen, abspielst
und was sonst noch so im Hintergrund laeuft.

Das Video memory hattest du, wie geraten, ueberprueft?


Ja, fast voll belegt :( 28 MB VRAM wenn ich mit dem OWB surfe und mit dem MPlayer Webradio höre.
www.amigalinux.org
Mini G4 1,42 MorphOS 3.6 reg.

Benutzeravatar
pegasossigi2
Romanverfasser
Romanverfasser
Beiträge: 695
Registriert: 09 Aug 2007, 13:16

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon pegasossigi2 » 22 Apr 2012, 01:36

Amiga4k:

Wieviel VMem hast du ?

Kannst du mal in Programm sys:Utilities/GraphicsBoards nachschauen ?

Edit: Ich habe grade gesehn du hast ja ein mit 32mByt.
Da mußt du wohl die Auflösung runterschrauben.
MacMini G4/1.5GHz, PowerBook G4 1.667 GHz

Benutzeravatar
Nordlicht
Quasselstrippe
Quasselstrippe
Beiträge: 431
Registriert: 01 Jan 2005, 22:46
Wohnort: Uelzen

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Nordlicht » 23 Apr 2012, 22:10

Um VMEM zu sparen reicht es die Farben der Screens zu reduzieren. Daneben kann auch ein Eintrag in den Tooltypes bei DEVS/Monitors/Radeon ein LOWMEMPROFILE=YES etwas bringen. Versuch macht kluch.
Gruß Nordlicht
Peg rocks around the world

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1690
Registriert: 12 Sep 2003, 15:55

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Andreas_Wolf » 23 Apr 2012, 23:02

> Daneben kann auch ein Eintrag in den Tooltypes bei DEVS/Monitors/Radeon ein
> LOWMEMPROFILE=YES etwas bringen.

Laut pega-1s Erklärung der Funktion dieses Tooltypes wird dadurch nur System-RAM gespart, kein VRAM.
http://www.pegasosforum.de/download/file.php?id=855

Benutzeravatar
analogkid
Moderator
Moderator
Beiträge: 2562
Registriert: 07 Sep 2003, 17:05
Wohnort: Ibbenbüren
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon analogkid » 25 Apr 2012, 08:29

Andreas_Wolf hat geschrieben:> Daneben kann auch ein Eintrag in den Tooltypes bei DEVS/Monitors/Radeon ein
> LOWMEMPROFILE=YES etwas bringen.

Laut pega-1s Erklärung der Funktion dieses Tooltypes wird dadurch nur System-RAM gespart, kein VRAM.


In den offiziellen Releasenotes zu 2.5 wird das auch vermerkt: http://www.morphos-team.net/releasenotes-2.5.html
Frail as ever, still the most severe

Benutzeravatar
analogkid
Moderator
Moderator
Beiträge: 2562
Registriert: 07 Sep 2003, 17:05
Wohnort: Ibbenbüren
Kontaktdaten:

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon analogkid » 25 Apr 2012, 08:35

Amiga4k hat geschrieben:Hi,

ich habe den Mini mit 32 MB VRAM, 1 GB RAM und 1,42 GHz CPU.

Wenn ich zwei MUI-Programme öffne, dann fängt der Mauszeiger an zu ruckeln und zu springen. Ich nutze z.B. auch gerne den MUI-OWB mit dem MPlayer zusammen. Wenn ich eine Seite mit dem OWB öffne, dann passiert es öfter, dass das Webradio stottert. Diese Probleme habe ich schon immer unter MorphOS auf dem Mini. Der Mac Mini ist aber einwandfrei in Ordnung. Ich habe neben MorphOS noch das neue Lubuntu 12.04 und Mac OS X 10.5.8 Leopard und Mac OS X 10.3.9 Panther installiert. Obwohl gesagt wird, dass MorphOS schneller und schlanker sein soll als die o.g. Systeme, sind bei mir die OS X-Systeme und (L)Ubuntu genauso schnell und bekommen das mit dem Multitasking perfekt hin. Obwohl Linux extrem aufgebläht ist, kann ich den neuesten Firefox 11 und den MPlayer gleichzeitig benutzen ohne das etwas ruckelt oder der Sound stottert.

Habe ich etwas vergessen einzustellen unter MorphOS? Oder fehlt mir irgendein Treiber-Paket?

Achja, es gibt unter Lubuntu auch ein Browser der so wie unser OWB ist. Dieser heißt Midori und baut genauso wie der OWB auf Webkit auf, ist aber ein wenig schneller im Seitenaufbau.

Vielleicht kann MorphOS 3.0 mit meinen anderen Systemen von der Geschwindigkeit her wieder gleichziehen. Ich habe gelesen, dass der AGP-Treiber verbessert wurde.


Dass aktuelle Versionen von MorphOS mit 32 MB VMEM schnell an ihre Grenzen kommen, ist schon länger bekannt, und die Symptome auch. Aus gutem Grund wird ja daher von den 32MB VMEM Systemen eher abgeraten, zumindest wenn diese als Hauptsystem benutzt werden soll. Wie Kronos (und auch andere in der Vergangenheit) bereits empfohlen haben, 64MB sind schon das Mindeste, was man für MorphOS heutzutage mitbringen muss. Mein Powermac frisst bei 3 1600x900 24bit-Screens, davon einer mit "Enhanced Layers", seine 35MB VMEM...
Frail as ever, still the most severe

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1690
Registriert: 12 Sep 2003, 15:55

Re: Probleme mit MorphOS 2.7 auf dem Mini

Beitragvon Andreas_Wolf » 25 Apr 2012, 08:44

> In den offiziellen Releasenotes zu 2.5 wird das auch vermerkt:
> http://www.morphos-team.net/releasenotes-2.5.html

In der Tat. Danke für die Ergänzung.
http://www.pegasosforum.de/download/file.php?id=855


Zurück zu „Mac“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast