Mac Mini Superdrive und MorphOS

Alles über MacOS und MacOnLinux

Moderatoren: analogkid, roschmyr

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1357
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Mac Mini Superdrive und MorphOS

Beitragvon DrB » 10 Jun 2010, 00:40

Nachdem ich das Combo Drive (DVD-ROM, CD Brenner) meines Mac Mini gegen
ein Superdrive (DVD Brenner) getauscht hatte, musste ich leider feststellen dass
MakeCD hiermit, im Gegensatz zum vorherigen ComboDrive, nicht mehr klar
kommt (Cmd WRITE_12 => Hardware Error: Communication Failure). Unter MacOS
funktioniert das Laufwerk hingegen ohne Probleme. Das ist jetzt etwas aergerlich, da
ich bisher primaer MakeCD zum CD brennen benutzt hatte und eigentlich auch nicht
mehr davon ausgegangen bin dass es noch sowas wie Kompatibilitaetsprobleme gibt
(zumal ich MakeCD schon mit einigen Brennern problemlos betrieben hatte).

Nun wuerde mich interessieren welche Kombinationen ihr (erfolgreich) im Mac Mini
unter MorphOS im Einsatz habt.

Das von mir verwendete Laufwerk ist uebrigens ein "Pioneer DVR-K05" mit der
Apple Firmware "Q523".

pega-1
Articia-Verehrer
Articia-Verehrer
Beiträge: 124
Registriert: 07 Mär 2004, 13:09

Re: Mac Mini Superdrive und MorphOS

Beitragvon pega-1 » 10 Jun 2010, 18:19

DrB hat geschrieben:Nachdem ich das Combo Drive (DVD-ROM, CD Brenner) meines Mac Mini gegen
ein Superdrive (DVD Brenner) getauscht hatte, musste ich leider feststellen dass
MakeCD hiermit, im Gegensatz zum vorherigen ComboDrive, nicht mehr klar
kommt (Cmd WRITE_12 => Hardware Error: Communication Failure). Unter MacOS
funktioniert das Laufwerk hingegen ohne Probleme. Das ist jetzt etwas aergerlich, da
ich bisher primaer MakeCD zum CD brennen benutzt hatte und eigentlich auch nicht
mehr davon ausgegangen bin dass es noch sowas wie Kompatibilitaetsprobleme gibt
(zumal ich MakeCD schon mit einigen Brennern problemlos betrieben hatte).

Nun wuerde mich interessieren welche Kombinationen ihr (erfolgreich) im Mac Mini
unter MorphOS im Einsatz habt.

Das von mir verwendete Laufwerk ist uebrigens ein "Pioneer DVR-K05" mit der
Apple Firmware "Q523".


Das Superdrive war doch ursprünglich ein Panasonic SlotIn ? Möglicherweise hättest Du damit mehr Glück .....

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1357
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Re: Mac Mini Superdrive und MorphOS

Beitragvon DrB » 10 Jun 2010, 21:15

pega-1 hat geschrieben:
DrB hat geschrieben:Das von mir verwendete Laufwerk ist uebrigens ein "Pioneer DVR-K05" mit der
Apple Firmware "Q523".


Das Superdrive war doch ursprünglich ein Panasonic SlotIn ? Möglicherweise hättest Du damit mehr Glück .....


Apple selber hat nach meinen Recherchen 3 verschiedene Typen verbaut (jeweils mit
eigener Firmware, wg., der Master/Slave Problematik beim Mini).

Ich will das jetzt auch gar nicht mehr tauschen, geht ja alles soweit bis aufs brennen
(hier gehe ich von einem MakeCD Problem aus), es interessiert mich aber einen Ueberblick
zu bekommen.

ForgottenHero
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1010
Registriert: 05 Dez 2005, 00:45
Wohnort: Hamburg
Kontaktdaten:

Re: Mac Mini Superdrive und MorphOS

Beitragvon ForgottenHero » 11 Jun 2010, 07:43

DrB hat geschrieben:
pega-1 hat geschrieben:
DrB hat geschrieben:Das von mir verwendete Laufwerk ist uebrigens ein "Pioneer DVR-K05" mit der
Apple Firmware "Q523".


Das Superdrive war doch ursprünglich ein Panasonic SlotIn ? Möglicherweise hättest Du damit mehr Glück .....


Apple selber hat nach meinen Recherchen 3 verschiedene Typen verbaut (jeweils mit
eigener Firmware, wg., der Master/Slave Problematik beim Mini).

Ich will das jetzt auch gar nicht mehr tauschen, geht ja alles soweit bis aufs brennen
(hier gehe ich von einem MakeCD Problem aus), es interessiert mich aber einen Ueberblick
zu bekommen.


Also mein Superdrive läuft bestens mit MakeCD unter MorphOS. Habe erst vor kurzem das MorphOS 2.5 ISO damit gebrannt.
Kann zur Zeit aber nicht prüfen welches Laufwerk es genau ist, weil ich nicht zu Hause bin. Aber ich bin mir auch sehr sicher das es ein Panasonic war. Werde aber zu Hause noch mal genau schauen.
Ich habe es nachträglich in den Mini gebaut. Ich glaube es war ein Laufwerk aus einem PowerBook.
Einige sagen jetzt das wurde auf dem Mini nicht laufen, weil diese Laufwerke auf Master eingestellt sind und nur per Firmeware auf Slave geschaltet werden können.
Was so auch richtig ist, aber laufen tun die Laufwerke auch am Mini.
Man muß einfach nur die Festplatte auf Slave jumpern und schon läuft es.
Das einzige was sich dann anders verhält ist das der Mini auch ohne drücken der C Taste von der MacOSX und MorphOS Install Disk startet. Was mich bisher noch nicht gestört hat.
MacMini 1,5Ghz,MorphOS 3.1
PowerBook G4 ,MorphOS 3.2

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1357
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Beitragvon DrB » 28 Jun 2010, 01:32

Das Thema hat mir doch keine Ruhe gelassen, ich habe nun ein
"Matshita UJ-875" mit der Firmware "DB09" erworben. Dieses
funktioniert nun ohne weitere Probleme auch mit MakeCD.
Wenn man will, dann gibt es sogar eine gepatchte rpc1 firmware
hierfuer. Master/Slave Probleme hatte ich nicht, das Laufwerk
laeuft, wie es soll, als Slave. Inzwischen bin ich mir auch gar
nicht mehr sicher ob die neueren Mac Mini G4 nicht sowieso
"cable select" unterstuetzen.
Zuletzt geändert von DrB am 28 Jun 2010, 22:51, insgesamt 1-mal geändert.

Benutzeravatar
geit
Seniormember
Seniormember
Beiträge: 857
Registriert: 30 Mär 2006, 12:17
Wohnort: 48477 Hörstel
Kontaktdaten:

Beitragvon geit » 28 Jun 2010, 17:05

Das Problem ist bereits vom MorphOS Team in einem Mac mini reproduzierbar und an einer Lösung wird gearbeitet.

Geit

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1357
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Beitragvon DrB » 28 Jun 2010, 22:49

geit hat geschrieben:Das Problem ist bereits vom MorphOS Team in einem Mac mini reproduzierbar und an einer Lösung wird gearbeitet.


Nun gut, ich haette jetzt nicht vermutet das MorphOS etwas damit zu tun
haben koennte. Nach meiner bescheidenen Vorstellung werden die Kommandos
ja nur ueber das ide.device an das Laufwerk durchgereicht, so dass ich den Fehler
eher in einem Timing Problem bei MakeCD gesehen hatte. Denn das Laufwerk
funktioniert ja ansonsten ohne Probleme (lesen, booten). Aus diesem Grund hatte
ich auch keinen Bug gemeldet.

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1693
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 28 Jun 2010, 23:27

> Inzwischen bin ich mir auch gar nicht mehr sicher ob die neueren
> Mac Mini G4 nicht sowieso "cable select" unterstuetzen.

Ich glaube nicht, dass die Silent-Upgrade-Varianten einen anderen IDE-Controller haben als die Versionen des Mac mini G4 davor.

Der Vollständigkeit halber mal die für dein Problem relevanten Threads bei Morphzone.org:

http://www.morphzone.org/modules/newbb_ ... m=11#74305
http://www.morphzone.org/modules/newbb_ ... 2&forum=11

pega-1
Articia-Verehrer
Articia-Verehrer
Beiträge: 124
Registriert: 07 Mär 2004, 13:09

Beitragvon pega-1 » 29 Jun 2010, 10:08

Andreas_Wolf hat geschrieben:> Inzwischen bin ich mir auch gar nicht mehr sicher ob die neueren
> Mac Mini G4 nicht sowieso "cable select" unterstuetzen.

Ich glaube nicht, dass die Silent-Upgrade-Varianten einen anderen IDE-Controller haben als die Versionen des Mac mini G4 davor.

Der Vollständigkeit halber mal die für dein Problem relevanten Threads bei Morphzone.org:

http://www.morphzone.org/modules/newbb_ ... m=11#74305
http://www.morphzone.org/modules/newbb_ ... 2&forum=11


Bisher sind uns nur gewisse SonyNec Optiarc und Pioneer Laufwerke als problematisch beim Brennen von optischen Medien gemeldet worden. Die typischerweise verwendeten Panasonic Laufwerke arbeiten offenbar anstandslos. Eine vorübergehende Lösung ist möglicherweise, den UDMA Betrieb des Laufwerks zu deaktivieren. Eventuell releasen wir da ein Tool als vorübergehenden Fix.

Benutzeravatar
mk
Forum Legende
Forum Legende
Beiträge: 1766
Registriert: 08 Sep 2003, 07:21
Wohnort: Gera

Beitragvon mk » 29 Jun 2010, 10:44

pega-1 hat geschrieben:
Andreas_Wolf hat geschrieben:> Inzwischen bin ich mir auch gar nicht mehr sicher ob die neueren
> Mac Mini G4 nicht sowieso "cable select" unterstuetzen.

Ich glaube nicht, dass die Silent-Upgrade-Varianten einen anderen IDE-Controller haben als die Versionen des Mac mini G4 davor.

Der Vollständigkeit halber mal die für dein Problem relevanten Threads bei Morphzone.org:

http://www.morphzone.org/modules/newbb_ ... m=11#74305
http://www.morphzone.org/modules/newbb_ ... 2&forum=11


Bisher sind uns nur gewisse SonyNec Optiarc und Pioneer Laufwerke als problematisch beim Brennen von optischen Medien gemeldet worden. Die typischerweise verwendeten Panasonic Laufwerke arbeiten offenbar anstandslos. Eine vorübergehende Lösung ist möglicherweise, den UDMA Betrieb des Laufwerks zu deaktivieren. Eventuell releasen wir da ein Tool als vorübergehenden Fix.

Die beiden Problempunkte:

- bei MakeCD falschen Treiber gewählt (CDR_SCSI3_ATAPI ausprobiert?)

- kein oder falscher Ländercode im Laufwerk eingestellt (kann in MacOS abgeändert, oder durch Einspielen einer anderen Firmware in das Laufwerk ganz abgeschaltet werden)

sind bereits ausgeschlossen worden?

Benutzeravatar
DrB
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1357
Registriert: 19 Sep 2004, 18:01
Wohnort: Hamburg-Harburg

Beitragvon DrB » 30 Jun 2010, 10:28

mk hat geschrieben:
pega-1 hat geschrieben:Bisher sind uns nur gewisse SonyNec Optiarc und Pioneer Laufwerke als problematisch beim Brennen von optischen Medien gemeldet worden. Die typischerweise verwendeten Panasonic Laufwerke arbeiten offenbar anstandslos. Eine vorübergehende Lösung ist möglicherweise, den UDMA Betrieb des Laufwerks zu deaktivieren. Eventuell releasen wir da ein Tool als vorübergehenden Fix.

Die beiden Problempunkte:

- bei MakeCD falschen Treiber gewählt (CDR_SCSI3_ATAPI ausprobiert?)


Um deine Fragen nicht unbeantwortet zu lassen, obwohl ich sie nach der direkten
Bestaetigung von Problemen mit bestimmten Laufwerken fuer nicht mehr ganz
angebracht halte.

Ja, natuerlich wurde das ueberprueft (nicht nur das), ich wuesste gar nicht
welcher Treiber sonst in Frage kommen wuerde.

mk hat geschrieben:- kein oder falscher Ländercode im Laufwerk eingestellt (kann in MacOS abgeändert, oder durch Einspielen einer anderen Firmware in das Laufwerk ganz abgeschaltet werden)


Den Ländercode hatte ich nicht abgecheckt, mir erschliesst sich aber auch nicht,
wie dieser dass Brennen einer CD-R behindern kann.

Benutzeravatar
mk
Forum Legende
Forum Legende
Beiträge: 1766
Registriert: 08 Sep 2003, 07:21
Wohnort: Gera

Beitragvon mk » 30 Jun 2010, 13:00

DrB hat geschrieben:
mk hat geschrieben:(CDR_SCSI3_ATAPI , Ländercode)

Ja, natuerlich wurde das ueberprueft (nicht nur das), ich wuesste gar nicht welcher Treiber sonst in Frage kommen wuerde.

Den Ländercode hatte ich nicht abgecheckt, mir erschliesst sich aber auch nicht, wie dieser dass das Brennen einer CD-R behindern kann.

Diese beiden Punkte waren die Usache von tatsächlich aufgetretenen, in anderen Foren behandelten Fehlern mit ähnlichen Symtomen (Zugriffsfehler, Fehler in den übertragenen Daten). Wenn ihr das für diesen Fall intern bereits als Ursache ausgeschlossen habt, dann betrachte es einfach als bislang zumindest hier im Forum noch nicht besprochenen und "nur" in anderen Fällen mit optischen Laufwerken nachgewiesen weiterhelfenden Tipp für Nutzer.
Zuletzt geändert von mk am 30 Jun 2010, 13:20, insgesamt 2-mal geändert.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2632
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 30 Jun 2010, 13:13

Jupp, selbst wenn es nicht ausschlaggebend sein sollte, gibt es dennoch eine gewisse Übersicht was alles probiert wurde :)
http://www.disk-doktor.de


Zurück zu „MacOS“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste