Catweasel MK4 für MorphOS

Das Mikrokernel-Betriebssystem für die PowerPC-Architektur

Moderatoren: analogkid, roschmyr

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 21 Nov 2010, 23:34

Hallo

Ich bekomme das Catweasel & CWDiskImage nicht gestartet, es verlangt ixemul.library in der version 50, da ich dies nicht habe, nutzte ich, das erste Ixemul v 50 m68k und später das v 63.1 m68k, leider funktioniert es immer noch nicht, es wird weiter verlangt das ixemul.library in der version 50.
Ich finde keine native ixemul.library für morphos 1.4.5 in http://morphos-files.net/categories/system/libraries , könntet ihr mir weiter helfen?

Quelle
http://www.amiga-news.de/de/news/AN-201 ... 52-DE.html
http://amiga.sourceforge.net/?showpacka ... ul.library

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 21 Nov 2010, 23:54

Was für ein MorphOS hast du drauf?
Schau mal auf der CD, welche Version die ixemul und ixnet libs haben. Prüf dann auch mal ob du rivalisierende Versonen in SYS:Libs und MOSSYS:Libs hast.
http://www.disk-doktor.de

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1691
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 22 Nov 2010, 01:43

> Was für ein MorphOS hast du drauf?

Zitat: "morphos 1.4.5"

Benutzeravatar
mk
Forum Legende
Forum Legende
Beiträge: 1766
Registriert: 08 Sep 2003, 07:21
Wohnort: Gera

Beitragvon mk » 22 Nov 2010, 03:13

Morphoyasha hat geschrieben:Ich bekomme das Catweasel & CWDiskImage nicht gestartet, es verlangt ixemul.library in der version 50, da ich dies nicht habe, nutzte ich, das erste Ixemul v 50 m68k und später das v 63.1 m68k, leider funktioniert es immer noch nicht,

Die verbugte, völlig regelwidrig inflationär versionierte (bis 6x.x) 68k Röschware versagt unter jeder MorphOS Version.
Morphoyasha hat geschrieben: es wird weiter verlangt das ixemul.library in der version 50.
Ich finde keine native ixemul.library für morphos 1.4.5 in http://morphos-files.net/categories/system/libraries ,

Ixemul für MorphOS gibt es dort auch gar nicht. MorphOS-1.4.5 beinhaltet bereits das (PPC native) ixemul 49.18.
Morphoyasha hat geschrieben: könntet ihr mir weiter helfen?

Das MorphOS Team kann Dir weiterhelfen. MorphOS ab 2.5 enthält das (PPC native) ixemul 50.1. Kauf Dir also bei denen einen Key für MorphOS-2.

MorphOS-2 lässt sich übrigens auch ohne Key mit nur einer einzigen Einschränkung testen. Es läuft ohne Key immer nur 30 Minuten am Stück, bevor nach (Re)Boot (wieder) eine Bremse zugeschaltet wird.

Benutzeravatar
analogkid
Moderator
Moderator
Beiträge: 2562
Registriert: 07 Sep 2003, 17:05
Wohnort: Ibbenbüren
Kontaktdaten:

Beitragvon analogkid » 22 Nov 2010, 12:30

Die freundlichere Kurzfassung: Die aktuelle Version benötigt MorphOS 2.5 oder neuer. Vielleicht kannst du dem Autor ja ein Feedback geben, ob er auch eine MorphOS 1.x kompatible Version bringen kann oder ob zwingende technische Gründe für die ixemul.library V50+ sprechen.
Frail as ever, still the most severe

pega-1
Articia-Verehrer
Articia-Verehrer
Beiträge: 124
Registriert: 07 Mär 2004, 13:09

Beitragvon pega-1 » 22 Nov 2010, 18:22

analogkid hat geschrieben:Die freundlichere Kurzfassung: Die aktuelle Version benötigt MorphOS 2.5 oder neuer. Vielleicht kannst du dem Autor ja ein Feedback geben, ob er auch eine MorphOS 1.x kompatible Version bringen kann oder ob zwingende technische Gründe für die ixemul.library V50+ sprechen.


Man könnte sich aber auch fragen, warum denn überhaupt ixemul nötig ist. Besser wird der Treiber dadurch sicherlich nicht .....

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 02 Dez 2010, 12:05

Ich habe mich an Ian gewant und eine antwort erhalten.


Hallo Martin,

(Google'd Deutsch hier: :) )
Entschuldigen Sie mein Schreiben in Englisch - ich spreche nicht richtig Deutsch!

Die Catweasel Trieber sollte unter keinen MorphOS System mit pcix.library installiert Arbeit. Haben Sie versucht, es läuft noch? Wenn es nicht funktioniert, könnten Sie laufen Sashimi und senden Sie mir die Debug-Ausgabe? Vielleicht kann ich es richtig läuft.

(Original English here!: )

The Catweasel driver should work under any MorphOS system with pcix.library installed. Have you tried running it yet? If it doesn't work, could you run Sashimi and send me the debug output? Maybe I can get it running.

Danke,

On Wed, 01 Dec 2010 22:22:25 -0000, Martin wrote:

> Ich habe über die Catweasel Treiber http://www.amiga-news.de/de/news/AN-201 ... 52-DE.html gelesen und war erfreut das es eine neuen Treiber für den Catweasel Mk4 gibt. Da ich leider mit MorphOS 1.4.5 unterwegs bin frage ich Sie, könnten Sie das Treiber Programm auch für MorphOS 1.4.5 Lauffähig machen?
>


--Ian Gledhill



So, wie soll ich weiter machen? Ich habe folgende Problemchen.

1. Problem: Die Catweasel MK4 Hardware hab ich noch nicht nur die MK3
2. Problem: Das pcix.library habe ich nicht im LIBS: & MOSSYS:LIBS, im aminet.net & morphos-files.net gibt es auch nicht zum Downloaden.
3. Problem: Zum Thema Debug-Ausgabe, reicht das aus, die Fehlmeldungs Ausgabe über SnoopDos? Per e-mail zu verschiken?
4. Problem: kennt jemand die e-mail Adresse von Sashimi oder ist das ein Programm?
Zuletzt geändert von Morphoyasha am 04 Dez 2010, 01:28, insgesamt 1-mal geändert.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 02 Dez 2010, 12:34

Sashimi ist ein Programm um Debugmeldungen zu protokollieren. Dazu bräuchtest du die MK4, und wenn sie nicht tut, die Debugausgabe protokollieren und diese an Ian senden.

Das deutsch ist wirklich schlecht von google, und hier kommen Missverständnisse auf:
Die Catweasel Trieber sollte unter keinen MorphOS System mit pcix.library installiert Arbeit
The Catweasel driver should work under any MorphOS system with pcix.library installed
Korrekte Übersetzung:
Die Catwaesel-Treiber sollten auf jedem MorphOS laufen, auf dem die pcix.library installiert ist.

Die openpci.library ist aber installiert? Schau mal mit Scout unter "Libraries" ob die pcix.library eingebunden wird (bin mir hier nicht sicher ob sie als Datei vorliegt oder von einem anderen Programm oder Lib "abgespaltet" wird)
http://www.disk-doktor.de

Benutzeravatar
analogkid
Moderator
Moderator
Beiträge: 2562
Registriert: 07 Sep 2003, 17:05
Wohnort: Ibbenbüren
Kontaktdaten:

Beitragvon analogkid » 02 Dez 2010, 12:52

Die pcix.library ist Bestandteil von MorphOS. "version pcix.library" bringt die Erkenntnis. ;-)
Frail as ever, still the most severe

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1691
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 02 Dez 2010, 13:13

> 1. Problem: Die Catweasel MK4 Hardware hab ich noch
> nicht nur die MK3

"I've just tested with my old CW MK3 on Peg2. It seems to work too (I was able to read Amiga and MSDOS disks) !"
http://www.morphzone.org/modules/newbb_ ... 9349#79349


> Dazu bräuchtest du die MK4

Wieso?

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 02 Dez 2010, 13:27

>> Dazu bräuchtest du die MK4

> Wieso?

Ok wenns mit der MK3 ebenso funktioniert, und gewährleistet ist, daß es auf der MK4 dann auch tut, dann kann er es mit der MK3 testen.
Ohne Karte nutzen die Debugausgaben nichts.
Ich bin eben von diesem Thread ausgegangen, und da bräuchte Ian eben die Debugausgaben mit der MK4, denn das war das Thema:

>das es eine neuen Treiber für den Catweasel Mk4 gibt. Da ich leider mit MorphOS 1.4.5 unterwegs bin frage ich Sie, könnten Sie das Treiber Programm auch für MorphOS 1.4.5 Lauffähig machen?
http://www.disk-doktor.de

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1691
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 02 Dez 2010, 13:43

> und gewährleistet ist, daß es auf der MK4 dann auch tut

Diese Richtung wird sicherlich unproblematisch sein. Wenn es Probleme gibt, dann eher andersrum.

> Ohne Karte nutzen die Debugausgaben nichts.

Ich glaube nicht, dass Morphoyasha versucht, einen Treiber zu verwenden, ohne die entsprechende Hardware installiert zu haben ;-)

> da bräuchte Ian eben die Debugausgaben mit der MK4, denn
> das war das Thema

Morphoyasha hat dieses Thema gewählt, weil es so in der AN-Meldung steht. In der AN-Meldung steht es so, weil Ian sich in der MorphZone nur auf die MK4 bezog. Ian bezog sich nur auf die MK4, weil er keine MK3 hat. Das muss aber eben in Bezug auf die MK3-Kompatibilität gar nichts heißen.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 02 Dez 2010, 13:49

Ok wenn Du so bescheid weißt, ist ja alles geklärt.
Ich dachte es ging mehr um die Kompatibilität des Treibers auf MOS1.4.5
http://www.disk-doktor.de

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1691
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 02 Dez 2010, 17:18

> wenn Du so bescheid weißt, ist ja alles geklärt.

Ich selbst weiß (fast) gar nichts zu dieser Sache, denn ich habe die nötige Hardware nicht. Ich kann aber lesen (und zitieren), was andere dazu geschrieben haben. Dazu benötige ich theoretisch nicht mal MorphOS.

> Ich dachte es ging mehr um die Kompatibilität des Treibers auf
> MOS1.4.5

Und was soll das mit MK3 vs. MK4 (darum ging es in meinem Beitrag, auf den du geantwortet hattest) zu tun haben? Verwirrend.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 02 Dez 2010, 17:20

Du und MY haben doch mit der MK3 angefangen..... und das "Wieso" er eine mk4 zum debuggen braucht hab ich dann eben genau darauf bezogen. MY meinte er hätte nur eine MK3, dann hast Du doch den Link geschrieben.
Ich habs nur weitergesponnen, nicht initiiert.
http://www.disk-doktor.de

Andreas_Wolf
Forum Legende
Forum Legende
Beiträge: 1691
Registriert: 12 Sep 2003, 15:55

Beitragvon Andreas_Wolf » 02 Dez 2010, 17:47

> Du und MY haben doch mit der MK3 angefangen

Ich habe gar nichts angefangen, sondern nur auf Morphoyashas Befürchtung, dass es mit der MK3 Probleme geben könnte, die es mit der MK4 nicht gibt, mit einem MorphZone-Zitat eines Users geantwortet, der behauptet, Ians Treiber erfolgreich mit einer MK3 getestet zu haben.
Und da verstehe ich nicht, was der Satz "Ich dachte es ging mehr um die Kompatibilität des Treibers auf MOS1.4.5" als Antwort auf einen Beitrag, in dem es um die Frage der Hardware-Kompatibilität geht, die ja erst mal Grundvoraussetzung ist, für einen Sinn haben soll. Es sind ja zwei getrennte Punkte, die nicht vermischt werden sollten: (1) Hardwarekompatibilität des Treibers mit MK3, (2) Softwarekompatibilität des Treibers mit MorphOS 1.4.5.
Ich habe mich heute hier im Thread lediglich zum ersten Punkt geäußert, der ja im Vergleich zum zweiten Punkt nicht minder relevant ist.
Zuletzt geändert von Andreas_Wolf am 02 Dez 2010, 19:27, insgesamt 2-mal geändert.

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 02 Dez 2010, 17:47

Hallo

Ich habe das Screen Abbildung Erstellt es scheint so das die pcxi.library existiert.
Ich hab an Ian allgemein gefragt, das sein Teiber für die Alte Morphos 1.4.5 machen könnte.
Aber das Problem besteht leider immer noch weil ich nicht die ixemul.library in der Version 50 habe nur die 49.18 und andere sehe hir viewtopic.php?p=46299#46299

Gibt es eine Möglichkeit die ixemul.library eine größere Version vorzugaukeln?
Dateianhänge
MOS-7.4.jpg
(504.39 KiB) 21-mal heruntergeladen

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 02 Dez 2010, 18:02

> Gibt es eine Möglichkeit die ixemul.library eine größere Version vorzugaukeln

Ja gibt es, wenn jedoch die Funktionalität fehlt hast Du ein Problem.
http://www.disk-doktor.de

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 03 Dez 2010, 16:29

Hallo Thore

Könnest du diesen Text (sehe PN) auf English übersetzten? Möchte diese an Ian weitergeben.
Danke.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 04 Dez 2010, 00:42

Hab sie mit ein paar Anmerkungen gemacht, schau in deine Inbox ;)
http://www.disk-doktor.de

Benutzeravatar
Kris
Articia-Verehrer
Articia-Verehrer
Beiträge: 244
Registriert: 24 Apr 2008, 10:40
Wohnort: Espoo / FIN

Beitragvon Kris » 05 Dez 2010, 10:21

Funktionieren alte Amiga Joysticks am Catweasel MK4Plus unter OS4.1/MorphOS 2.x?

Ich habe mir so einen Controller am Freitag bestellt mit der Hoffnung, dass zumindest in Zukunft diese Option bereit gestellt wird. Über einen derzeitigen Stand konnte mir niemand ein konkretes JA oder NEIN geben.
-= Master and Commander =-

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 05 Dez 2010, 14:13

Kris hat geschrieben:Funktionieren alte Amiga Joysticks am Catweasel MK4Plus unter OS4.1/MorphOS 2.x?

Ich habe mir so einen Controller am Freitag bestellt mit der Hoffnung, dass zumindest in Zukunft diese Option bereit gestellt wird. Über einen derzeitigen Stand konnte mir niemand ein konkretes JA oder NEIN geben.


Hm, das hatte man schon bei MK2, MK3 auch gesagt, leider liegen die Treiber aktuell immer noch im Windows XP und Linux bei, bei Älteren Amiga Magazinen wurde berichtet das jemand daran arbeitet würde ist aber mehr als 10 Jahre her. Ich würde dir Raten an Ian zu wenden (das mach ich auch zu zeit) um weitere Treiber für Catweasel um zusetzten.

Benutzeravatar
Kronos
Moderator
Moderator
Beiträge: 724
Registriert: 07 Sep 2003, 01:10
Wohnort: Hagen

Beitragvon Kronos » 05 Dez 2010, 14:51

Wobei ich mich frage ob du grad am Peg nicht mit nem einfachen Adapter besser bedient wärst....

Hab auf die schnelle nur nen 4fach-Adapter für den Parport gefunden, aber auch für den PC-Gameport sollte da was zu machen sein (denke mal das könnte sogar ein reiner Kabeladapter sein).
!! Bin Wichtig !!

Benutzeravatar
Kris
Articia-Verehrer
Articia-Verehrer
Beiträge: 244
Registriert: 24 Apr 2008, 10:40
Wohnort: Espoo / FIN

Beitragvon Kris » 05 Dez 2010, 15:06

Ein Catweasel soll evtl mal auch in mein SAM Flex kommen. Daher wäre eine Joystickunterstützung wünschenswert. Darüber hinaus möchte ich unter VICE meine Original Floppys von C64 und C16 nutzen.
Mit Ian habe ich vor einiger Zeit gemailt und mein Anliegen mitgeteilt. kurz danach kam die MorphOS und PEG II Unterstützung raus.
-= Master and Commander =-

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 11 Dez 2010, 03:10

Hallo Kris

Falls du Catweasel mk4plus im Pegasos2 eingebaut hast, könntest du einmal probieren dies auch unter MorphOS 1.4.5 laufen zu lassen und deine Ergebnisse Posten?

Danke.

Benutzeravatar
Kris
Articia-Verehrer
Articia-Verehrer
Beiträge: 244
Registriert: 24 Apr 2008, 10:40
Wohnort: Espoo / FIN

Beitragvon Kris » 11 Dez 2010, 19:04

Der Catweasel ist heute nach 6 Tagen Reise (unglaublich, dass HERMES satte 6 Tage für eine lieferung braucht) angekommen. Es scheint zu funktionieren mit dem aktuellen Treiber. Nur ist mein Diskettenlaufwerk (steht auch in der CW Anleitung) mit der Karte nicht kompatibel, insbesondere bei DD Disketten. Ich habe hier alles durchsucht und HD Disketten konnte ich keine auftreiben.
Darüber hinaus habe ich keine MorphOS 1.4.5 Installation, nur 2.7.

Hast du keine Möglichkeit, kurz auf 2.7 umzusatteln?
-= Master and Commander =-

Benutzeravatar
Morphoyasha
FireWire-Beschwörer
FireWire-Beschwörer
Beiträge: 1104
Registriert: 19 Sep 2005, 18:30
Wohnort: Detmold

Beitragvon Morphoyasha » 12 Dez 2010, 01:42

Hallo Kris

So ich habe heute morgen par Rohlinge gekauft um die Morphos 2.7 drauf zu brennen.
Da ich absolut keine freie Partition habe, packte ich die Treiber in einen usb Stick und habe einen keinen Script gebastelt die so ausieht...

Assign „Devs:“ Stick:Floppytest/Devs ADD (catweasel.device ist enthalten)
Mount Stick:Floppytest/devs/Dosdrivers/TD0

Das ganze mit Iconx gestartet. Das Laufwerk reagiert jedenfalls, Sprich LED Blinkt.
Habe einen Amiga Diskette reingeleckt (auch andere) und erhalte eine Fehlmeldung die gleiche wie unter MorphOS 1.4.5, die sagt...

Volume in device td0 has a error on disk Block 0

Jetzt bin ich aber baff, auch unter MorphOS 2.7 funktioniert es nicht also liegt es nicht nur bei MorphOS 1.4.5.
Aber im Morphzone wird berichtet das es unter MorphOS funktioniert, Aber im welcher Plattform und welche Catweasel Karte funktioniert es?

Natürlich habe ich es auch unter AmigaOS 4.1.2 am laufen, dort geht alles ohne weitere problemen mit der gleichen Hardwaren.

Thore
Blue Morpho
Blue Morpho
Beiträge: 2631
Registriert: 30 Jul 2006, 18:09
Wohnort: Reutlingen
Kontaktdaten:

Beitragvon Thore » 12 Dez 2010, 13:04

Lass Dir mal von jemand anderem bei dems läuft das Treiberpaket schicken und probiers damit aus. Wenn deine defekt sind oder falsch, dann können wir dieses schonmal ausschließen.
http://www.disk-doktor.de


Zurück zu „MorphOS“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste